“MySql.Data.MySqIClient.MySqlProviderSevices”违反了延续安全 性规则。派生类型必须跟基类型的安康而访问性匹配或者比较基类型的安 全可访问性低。 “解决方法。”MySql.Data.MySqIClient.MySqlProviderSevices”违反了持续安全 性规则。派生类型必须跟基类型的安康而访问性匹配或者比较基类型的安 全可访问性低。 “解决方式。

by admin on 2018年10月5日

写Code First
时(使用的是MySql数据库),添加好EntityFrame、MySql.Data
、MySql.Data.Entity后 ,写好TestDbContext类。

形容Code First
时(使用的凡MySql数据库),添加好EntityFrame、MySql.Data
、MySql.Data.Entity后 ,写好TestDbContext类。

运作时报出一个”MySql.Data.MySqIClient.MySqlProviderSevices”违反了延续安全
性规则。派生类型必须跟基类型的安全而访问性匹配或者正如基类型的安
全而访问性低。 “

运作时报出一个”MySql.Data.MySqIClient.MySqlProviderSevices”违反了继续安全
性规则。派生类型必须同基类型的平安而访问性匹配或者正如基类型的安
全而访问性低。 “

如图图片 1百度,折腾几只钟头后,发现是MySql.Data
、MySql.Data.Entity的风行版本(6.10.4)有问题。

如图图片 2百度,折腾几只钟头后,发现是MySql.Data
、MySql.Data.Entity的新星版本(6.10.4)有问题。

报错各个版本如下:

报错各个版本如下:

install-package EntityFramework Version 6.2.0

MySql.Data Version 6.10.4

MySql.Data.Entity Version 6.10.4
install-package EntityFramework Version 6.2.0

MySql.Data Version 6.10.4

MySql.Data.Entity Version 6.10.4

 

 

跟换如下版本即可:

跟换如下版本即可:

install-package EntityFramework Version 6.2.0

MySql.Data Version 6.9.10

MySql.Data.Entity Version 6.9.10
install-package EntityFramework Version 6.2.0

MySql.Data Version 6.9.10

MySql.Data.Entity Version 6.9.10

 

 

相关文章

发表评论

电子邮件地址不会被公开。 必填项已用*标注

网站地图xml地图